Announcement

Collapse
No announcement yet.

turn signsls not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • turn signsls not working

    turn signals worked when parked....now they are not working along with the hazards.wipers still work,headlights,tail,and brake lights work.think i read here on the forums to hit the steering column with wd40 through the hazard switch?i searched but couldn't find it.thanks in advance for any help.
    2005 IASCA WORLD CHAMPION

  • #2
    The electical contacts in the steering column can get dirty and corroded. Sometimes spraying WD-40 or contact cleaner into the switch or ignition keyhole and working it around can fix the problem. For the turn singals there is also a device which turns them on and off which may be the source of your problems. Since the hazards also turn on and off it looks like a likely cause of your problem. It's pretty standard stuff so if you search here or on the Internet under "turn singals" or "turn signals not working" or something similar you should get some ideas on how to fix it yourself. BTW car maufacturers don't make electronics. They buy them. You should be able to use some generic device if that's your problem..
    Last edited by WmWatt; 06-08-2021, 07:13 AM.
    Original owner of silver grey carburetted 1989 Festiva. 105k km as of June 2006.

    Comment


    • #3
      thanks for the reply..i'll start with the contact cleaner and go from there.
      2005 IASCA WORLD CHAMPION

      Comment


      • #4
        Is you signal switch loose or does it still click into position and is it being returned to it's center position when the steering wheel is turned and then re-centered?
        There are plastic pieces inside the multifunction switch that break over time and can prevent the signal from working correctly.
        When searching for problems on the forum for this issue use the terms "combo switch" or "multifunction switch" and you will get more hits.

        Comment


        • #5
          thanks for the reply.it does click back into place and contacts have been cleaned as well.
          2005 IASCA WORLD CHAMPION

          Comment


          • #6
            i've cleaned the contacts,swapped out the multifunction switch,swapped out relays,no blown fuses..i ordered a new box that goes on the multifunction switch to see what happens...running out of options....
            2005 IASCA WORLD CHAMPION

            Comment


            • #7
              Sounds like it might be time to get out the VOM and start checking all the pretty coloured wires for power.
              Original owner of silver grey carburetted 1989 Festiva. 105k km as of June 2006.

              Comment

              Working...
              X