Announcement

Collapse
No announcement yet.

Nice tidbit for those with barely any heat

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ok, by the main plenum baffle you mean the one that controls hot/cold right? I was so sure it was my heater core when i changed it that i didn't look at anything else...
    Ok, when i change my radiator i will pull some hoses while its running and see how the flow is to check if anything is plugged.
    Thanks.


    Sent from my iPhone using Tapatalk

    Comment


    • To see how bad your seals are, you can put the mode selector to floor heat. You don't have to turn on the fan or set the temp to heat. You should not get any airflow through the dash vents in that position.
      "Blue92"- 92L 5 spd, original owner- 185K, B8,DD..
      "Pedro"-88L 5-spd, B6D (built by Advancedynamix)
      "Blanca"-92 GL auto, 125K(FM8 Lowest Miles)- B6 daughter's DD
      "Tractor Blue"- 89 L auto, 110K
      "Chester"-88 LX, runs but not street legal
      "Wenona"-89L parts car
      "Flame"- 89 LX 5 spd ,parts car

      Comment


      • Nice tidbit for those with barely any heat

        That was a funny experiment! I tried that this morning on the way to work. Moved the lever from windshield to just feet and i think more air came out the windshield vents! Lol, guess i know what i have to fix now. Thanks


        Sent from my iPhone using Tapatalk
        Last edited by ryanprins13; 08-10-2015, 11:30 PM.

        Comment


        • I finally found the motivation to change out my thermostat. Now I know why my car would barely heat up. There wasn't a thermostat in it! I installed the Mazda thermostat. I couldn't get it to install with the small valve at 12:00 due to a boss in the head casting. I had to install it about 1:00. Now the needle goes to about 1/4' above the normal line.
          Rick
          1993 Ford Festiva
          1986 AMC Eagle Wagon 4.2L/4.0L head, AW4,NP242, Chrysler 8.25" rear. SOLD
          1981 AMC Eagle Wagon-As Seen on TV Lost In Transmission
          2000 Ford E350

          Comment


          • 1/4 - 1/3 over cold is where my 89L four speed ran when it was new. Well, it was two years old with 22,700 miles on it. So that's the way it was set up from the factory.
            youtube.com/neanderpaul 88 festiva LX w/BP G25 MR 5 speed waiting for wiring- 93 Festiva GL auto w/ air, waiting for B6t/G4A-HL - 98 Nissan Quest - 02 Mazda protege 5 wife's DD

            Comment


            • My Festiva was making barely lukewarm heat and I already had the Mazda thermostat, maybe four years old. I said to heck with it and got a Gates 33489S 195 degree Tstat from Rockauto. Put it in tonight and what a difference! It is actually making enough heat to survive now! Maybe these Mazda ones get worn out over time and we don't notice it. I just need to top it off with coolant again after it cools down some and then I will be ready for an Arctic trip.

              Comment


              • I'm getting good heat out of mine but the gauge never moves (it hasn't been over 60.f outside here since I've owned the car though)

                New radiator was installed before I bought it, It does leak coolant somewhere near the drivers side of the engine, so I need to track that down, not sure what kind of tstat is in it at the moment.

                Reading through this whole thread it seems like the temp gauge not moving in the colder months is a fairly common thing with these cars, just worried about overheating after owning a lot of K-motor Mopar's and having to get the head milled after it overheated and warped a few too many times in my Dakota (offroad adventures snagging a lower rad hose yay!)
                1991 Festiva - Newest Toy
                1986 Horizon - The Race Car
                1993 Suburban 2500 - The Workhorse
                1995 Dakota 4cyl - The Eternally Broken

                Comment


                • All my festival, same thing. The fan cycles on and off and the temp gauge is still below the half mark compared to Toyota's which say they are good to go after 30 seconds. I considered moving the sensor for the gauge to a different location, changing sensor, nah. Install an aftermarket. and yes the new 195s are killer, same one in my truck b2200.
                  1993 GL 5 speed

                  It's a MazdaFordnKia thing, and you will understand!

                  Comment

                  Working...
                  X